Site is degraded

Incident Report for Udemy

Resolved

We have resolved the stability issue on our mobile app, and performance is back to normal. We appreciate your patience.
Posted Jun 22, 2025 - 00:42 UTC

Investigating

We're currently experiencing stability issues with the Udemy mobile app. Our engineering team is actively working to resolve the problem as quickly as possible. We appreciate your patience in the meantime.
Posted Jun 21, 2025 - 16:48 UTC
This incident affected: Udemy Business and Udemy.com (Marketplace).