A fix has been implemented and we are monitoring the results.
Posted Feb 14, 2026 - 22:00 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 14, 2026 - 21:58 UTC
Investigating
We are currently experiencing a stability issue with the 'Contact Us' button in the Help Center on the Udemy.com website. Our engineering team is actively working to resolve the problem as quickly as possible. In the meantime, please use https://business-support.udemy.com/hc/en-us/requests/new to reach out to support.