Cloudfare incident - Site degraded

Incident Report for Udemy

Resolved

The Cloudflare-related impact has been resolved. All systems are functioning as expected, and the incident is now cleared.
Posted Nov 18, 2025 - 15:13 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 18, 2025 - 12:56 UTC

Update

Service disruption.

This issue began at 11:48 UTC. Our partner Cloudflare is experiencing a problem that affects logins to Udemy and Udemy Business, password resets, and video playback.

You may see errors when trying to sign in or watch content.

It's still ongoing, we will share more updates as they come in.

Thank you for your patience.
Posted Nov 18, 2025 - 12:11 UTC

Identified

Our site is currently experiencing a stability issue - our engineering team is currently working to resolve it.
This may impact both Udemy business and Udemy.com
Symptoms are resetting passwords and viewing videos on the site.
Posted Nov 18, 2025 - 12:10 UTC
This incident affected: Udemy Business and Udemy.com (Marketplace).