Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted 2 years ago. May 31, 2023 - 14:00 UTC
Scheduled
We will be performing routine site maintenance between the hours of 6am–10am Pacific Time on Wednesday the 31st of May. During this time you may experience reduced performance or functionality. We apologize for the inconvenience.
Posted 2 years ago. May 22, 2023 - 15:52 UTC
This scheduled maintenance affected: Udemy Business and Udemy.com (Marketplace).