UB Pro Users are unable to launch labs in Practice mode

Incident Report for Udemy

Resolved

Resolved: Stability Issues - Jupyter Notebook Labs
Status Update Message
Resolved - The stability issues affecting Jupyter Notebook Labs have been fully resolved. After a period of monitoring, we have confirmed that the system is stable and operating at normal parameters. We apologize for any disruption this may have caused.
Posted Mar 05, 2026 - 16:14 UTC

Monitoring

[Monitoring] Stability Issues: Jupyter Notebook Lab
Our investigation confirmed that stability issues were isolated to Jupyter Notebook Labs. The root cause has been addressed, and we are now in a monitoring phase while the system returns to normal operating parameters.
Posted Mar 05, 2026 - 15:14 UTC

Investigating

The Labs feature on our UB site is currently experiencing stability issues - our engineering team is currently working to resolve it.
Posted Mar 05, 2026 - 11:27 UTC
This incident affected: Udemy Business.