This incident has been resolved. Performance has returned to normal across the platform. Our engineering team has confirmed stability and will continue to monitor as a precaution. Thank you for your patience while we worked to address this.
Posted Apr 20, 2026 - 16:25 UTC
Monitoring
We are seeing signs of recovery following earlier performance degradation across the platform.
Users should experience improved load times, and services are stabilizing. Our engineering team continues to monitor closely to ensure full resolution.
We will provide another update once monitoring is complete or if any changes occur.
Posted Apr 20, 2026 - 16:14 UTC
Update
We are continuing to investigate this issue.
Posted Apr 20, 2026 - 16:03 UTC
Investigating
Our site is experiencing a stability issue - We're looking into this, and we'll report back as more information becomes available.
Posted Apr 20, 2026 - 15:45 UTC
This incident affected: Udemy Business and Udemy.com (Marketplace).