A fix has been implemented and we are monitoring the results.
Posted Apr 13, 2026 - 16:21 UTC
Investigating
We are currently investigating an issue where some learners may be receiving an usually high number of email notification from the platform.
Our engineering team is actively working to identify the root cause and mitigate the impact. We understand this may be disruptive and appreciate your patience while we resolve the issue.
Posted Apr 12, 2026 - 16:36 UTC
This incident affected: Udemy Business and Udemy.com (Marketplace).