Critical component on our site is degraded

Incident Report for Udemy

Resolved

Status: Resolved

We have resolved the stability issues affecting the login feature on our site. Performance is back to normal.

This issue impacted both Udemy Business and Udemy.com users attempting to log in with passwordless code authentication, resulting in “403 Forbidden” errors.

We appreciate your patience while our engineering team worked to restore normal functionality.
Posted Oct 27, 2025 - 23:36 UTC

Monitoring

Status: Monitoring

The login feature on our site recently experienced stability issues. Our engineering team implemented a fix, and the system is now stable.

This may have impacted both Udemy Business and Udemy.com users logging in with passwordless code authentication.

Symptoms included “403 Forbidden” errors when attempting to log in through the website or mobile app.

The team is monitoring the results to ensure continued stability and will update again if further action is needed.
Posted Oct 27, 2025 - 23:35 UTC

Investigating

Users are unable to access their accounts on the Udemy website and mobile app when logging in with passwordless code authentication. Affected users encounter "403 Forbidden" errors during login. This blocks access to all web-based account features. Monitoring shows a significant spike in failed login attempts across both web and mobile platforms.
Posted Oct 27, 2025 - 22:31 UTC
This incident affected: Udemy Business and Udemy.com (Marketplace).