Personal Plan pricing display issue (Minor)

Incident Report for Udemy

Resolved

This incident has now been resolved. Thank you for your patience.
Posted Nov 03, 2025 - 17:14 UTC

Investigating

Some users may notice Personal Plan prices showing in USD instead of their local currency. The correct local price appears at checkout. The issue is intermittent and does not affect billing or payments. Our team is aware and monitoring the situation.
Posted Nov 01, 2025 - 16:54 UTC
This incident affected: Udemy.com (Marketplace).