We have resolved the stability issue on our site, and performance is back to normal. We appreciate your patience.
Posted 9 months ago. Jul 03, 2024 - 16:04 UTC
Identified
Our site is currently experiencing a stability issue - our engineering team is currently working to resolve it. This may impact both Udemy business and Udemy.com.
Symptoms are intermittent errors and slowness on the site.
Posted 9 months ago. Jul 03, 2024 - 15:59 UTC
Investigating
Our site is experiencing a stability issue - We're looking into this, and we'll report back as more information becomes available.
Posted 9 months ago. Jul 03, 2024 - 15:51 UTC
This incident affected: Udemy Business and Udemy.com (Marketplace).