Udemy Business MCP authentication issues

Incident Report for Udemy

Resolved

All SSO login/sign-up issues and Udemy Business MCP authentication issues have been resolved. Both standard SSO access and MCP-based AI tool integrations are now working normally.
Posted Mar 12, 2026 - 18:57 UTC

Update

SSO login has been restored. We are now focused on a remaining issue where some users cannot authenticate to the Udemy Business MCP Server for AI tool integrations. Our team is investigating and deploying fixes.
Posted Mar 12, 2026 - 16:35 UTC

Investigating

We are currently investigating an issue affecting Single Sign-On (SSO) for some users following a recent authentication service migration.

At this time, most existing users can log in via SSO but may have experienced failures earlier.

New users attempting to sign up via SSO are still impacted. They may see a generic error message or be redirected back to the login page after attempting SSO.

We will provide updates here as we make progress.

As a temporary workaround, where available in your organization, users may log in using a non‑SSO method (e.g., email and password) while we complete our SSO remediation.
Posted Mar 12, 2026 - 16:15 UTC
This incident affected: Udemy Business.