Media Processing Delays

Incident Report for Udemy

Resolved

This incident has been resolved.
Posted Jun 24, 2026 - 22:28 UTC

Update

We are currently aware of an issue where some media uploads may experience extended processing times. Uploaded media, including videos and images, may remain in a “Processing” state longer than expected.
Posted Jun 24, 2026 - 18:56 UTC

Identified

We are currently aware of an issue where some video uploads may experience extended processing times. Uploaded videos may remain in a "Processing" state longer than expected.
Who is impacted: Instructors uploading video content on the platform.
Posted Jun 24, 2026 - 18:46 UTC
This incident affected: Udemy Business and Udemy.com (Marketplace).