We have resolved the stability issue on our site, and performance is back to normal. We appreciate your patience.
Posted 2 years ago. May 04, 2023 - 16:35 UTC
Identified
Our site is currently experiencing a stability issue - our engineering team is currently working to resolve it. This may impact Udemy Business. Symptoms are intermittent errors and slowness on the site.
Posted 2 years ago. May 04, 2023 - 16:15 UTC
Investigating
Our site is experiencing a stability issue - We're looking into this, and we'll report back as more information becomes available.