Performance on our site is degraded
Incident Report for Udemy
Resolved
We have resolved the stability issues on our site, and performance is back to normal.
Posted Jun 23, 2022 - 20:42 UTC
Update
We are continuing to investigate this issue.
Posted Jun 23, 2022 - 16:46 UTC
Investigating
Our site is currently experiencing performance issues and is slower than usual. Our engineering team is currently working to resolve it.
Posted Jun 23, 2022 - 15:16 UTC